FreeRDP 2.0.0 before 3.32.0, when built with WITH_LAME=ON and WITH_DSP_FFMPEG=OFF, has a heap-based buffer overflow in
Affects freerdpSource GCVE Database
Not known to be exploited · CVSS 7.1 High · fixed in 3.32.0+dfsg-0ubuntu0.24.04.1 : patch freerdp soon.
Data as of 28 Oct 2026, 23:42 UTC
- Patch
- Available – fixed in 3.32.0+dfsg-0ubuntu0.24.04.1, 3.32.0+dfsg-0ubuntu0.26.04.1
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 14 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the Ubuntu freerdp3 to 3.32.0+dfsg-0ubuntu0.24.04.1 (package) or 3.32.0+dfsg-0ubuntu0.26.04.1 (package).
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSfreerdp3pkg:deb/ubuntu/freerdp3?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSfreerdp3pkg:deb/ubuntu/freerdp3?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu Pro 24.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-apps/nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-infra/focalOther threats | Affected
| Fixed in– |
Ubuntu Pro 18.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-infra/bionicOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in FreeRDP version 3.32.0 and later. Users and administrators should upgrade affected FreeRDP installations to version 3.32.0 or newer to remediate this vulnerability. No additional mitigations are specified by the vendor advisory.
Description
FreeRDP versions before 3.32.0, when built with WITH_LAME=ON and WITH_DSP_FFMPEG=OFF, contain a heap-based buffer overflow vulnerability in the MP3 decoding function. This flaw allows a malicious RDP server to send crafted MP3 audio data that causes the client to crash by overflowing heap memory.
References
- ubuntu.com/security/CVE-2026-110837 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-110837 (opens in a new tab)
- github.com/FreeRDP/FreeRDP/security/advisories/GHSA-52xc-5973-w5vv (opens in a new tab)
- vulncheck.com/advisories/freerdp-2.0.0-before-3.32.0-heap-buffer-overflow-via-mp3-audio-decoding (opens in a new tab)