FreeRDP from 2.0.0 before 3.32.0 contains a memory exhaustion vulnerability in wts_read_drdynvc_data_first that allows
Affects freerdpSource GCVE Database
Not known to be exploited · CVSS 6.5 Medium · fixed in 3.32.0+dfsg-0ubuntu0.24.04.1 : update freerdp when convenient.
Data as of 28 Oct 2026, 23:57 UTC
- Patch
- Available – fixed in 3.32.0+dfsg-0ubuntu0.24.04.1, 3.32.0+dfsg-0ubuntu0.26.04.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 14 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the Ubuntu freerdp3 to 3.32.0+dfsg-0ubuntu0.24.04.1 (package) or 3.32.0+dfsg-0ubuntu0.26.04.1 (package).
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSfreerdp3pkg:deb/ubuntu/freerdp3?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSfreerdp3pkg:deb/ubuntu/freerdp3?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu Pro 24.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-apps/nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-infra/focalOther threats | Affected
| Fixed in– |
Ubuntu Pro 18.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-infra/bionicOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and the vulnerability is fixed in FreeRDP version 3.32.0 and later. Users should upgrade to version 3.32.0 or newer to remediate this issue. Since the vulnerability requires authenticated access, restricting access to trusted users and monitoring for unusual memory usage may help mitigate risk until patching is applied.
Description
FreeRDP versions from 2.0.0 up to but not including 3.32.0 contain a memory exhaustion vulnerability in the wts_read_drdynvc_data_first function. Authenticated clients can exploit this flaw by sending a crafted DATA_FIRST message that declares a large 32-bit length, causing the server to allocate excessive zeroed memory and potentially exhaust server resources. This vulnerability has been assigned CVE-2026-110832 and is rated medium severity with a CVSS score of 6.5. Fixed versions are available starting from 3.32.0.
References
- ubuntu.com/security/CVE-2026-110832 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-110832 (opens in a new tab)
- github.com/FreeRDP/FreeRDP/security/advisories/GHSA-5cgr-vmp8-fmvj (opens in a new tab)
- vulncheck.com/advisories/freerdp-2.0.0-before-3.32.0-memory-exhaustion-via-drdynvc-data-first (opens in a new tab)