Skip to main content
VulnerabilityPublished

CVE-2024-27091: GeoNode · Stored XSS to full account takeover

Affects geonodeSource GCVE Database

0
Compare

Not known to be exploited · CVSS 6.1 Medium : upgrade to 4.2.3 when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.2.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade geonode to 4.2.3.

Affected software

ProductAffectedFixed in
PyPIgeonodeAffected
  • >=3.2.1 <4.2.3
Fixed in
  • 4.2.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, users should exercise caution when interacting with untrusted content in the rich text editor. Consider disabling or restricting rich text input if feasible.

Description

GeoNode versions 3.2.1 up to but not including 4.2.3 contain a stored cross-site scripting (XSS) vulnerability in the rich text editor. This vulnerability allows an attacker to retrieve a victim's CSRF token and perform actions such as changing the victim's email address, potentially leading to full account takeover. The vulnerability bypasses CORS policy restrictions due to the script element's behavior. The issue is classified as CWE-79 and has a moderate severity rating.

References

Community reviews

Loading reviews…