CVE-2026-15975: GitLab Has Remediated an Issue
Affects gitlabSource GCVE Database
Not known to be exploited · CVSS 7.5 High · fixed in 19.2.1 : patch gitlab soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 19.2.1, 19.1.3, 19.0.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 29 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade gitlab-org/gitlab to 19.2.1, 19.1.3 or 19.0.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
RubyGemsgitlab-org/gitlabpkg:gem/gitlab-org/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability has been officially fixed by GitLab. Users should upgrade to versions 19.0.5 or later for the 11.8+ to 19.0.x range, 19.1.3 or later for the 19.1.x range, and 19.2.1 or later for the 19.2.x range. No additional mitigation is required once upgraded.
Description
A vulnerability in GitLab CE/EE versions from 11.8 before 19.0.5, 19.1 before 19.1.3, and 19.2 before 19.2.1 could allow an unauthenticated user to cause a denial of service. The issue arises from insufficient resource throttling when processing merge request discussions. This vulnerability has been remediated in the specified fixed versions.