Skip to main content
VulnerabilityPublished

CVE-2026-3093: GitLab Has Remediated an Issue

Affects gitlabSource GCVE Database

0
Compare

Not known to be exploited · CVSS 4.7 Medium · fixed in 19.2.1 : update gitlab when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
4.7Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 19.2.1, 19.1.3, 19.0.5
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade gitlab to 19.2.1, 19.1.3 or 19.0.5.

Affected software

ProductAffectedFixed in
RubyGemsgitlabpkg:gem/gitlabOther threatsAffected
  • <19.0.5 >=14.0
  • <19.1.3 >=19.1
  • <19.2.1 >=19.2
Fixed in
  • 19.0.5
  • 19.1.3
  • 19.2.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and has been released by GitLab. Users should upgrade affected GitLab CE/EE instances to versions 19.0.5, 19.1.3, or 19.2.1 or later to remediate this vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

A vulnerability in GitLab CE/EE versions from 14.0 before 19.0.5, 19.1 before 19.1.3, and 19.2 before 19.2.1 allows an attacker to execute arbitrary JavaScript in another user's browser via a crafted URL. This occurs due to improper sanitization of user-controlled input, leading to a cross-site scripting (XSS) issue. The vulnerability has been remediated in the specified fixed versions.

References

Community reviews

Loading reviews…