Skip to main content
CVE-2026-97229VulnerabilityPublished Updated

GitLab Has Remediated an Issue

Affects gitlabSource GCVE Database

0
Compare
Authoritative record:CVE-2026-97229· Critical 10.0

Exploited in the wild · KEV due 1 Nov 2026 · public exploit available (Metasploit) : apply the vendor's fix or mitigations to gitlab now.

Data as of 31 Oct 2026, 04:22 UTC

CVSS 3.1 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitLab)CVSS 3.110.0
KEV deadline
 US federal agencies must patch by this date; a sensible deadline for everyone else. Other KEV due dates
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 13 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    1 Metasploit module

  4. Exploited in the wild: evidence found.

    Listed in CISA KEV 16 days after disclosure

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by GitLab Inc.

    , 19 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. CISA SSVC assessment

    exploitation active

    , 16 days after disclosure

  4. In Threat Radar

    record ingested

    , 16 days after disclosure

  5. , 16 days after disclosure

  6. KEV remediation due

    US federal deadline

    , 19 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA KEV (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 16.04 LTSgitlabpkg:deb/ubuntu/gitlab?arch=source&distro=xenialOther threatsAffected
  • =8.4.3+dfsg-9
  • =8.4.3+dfsg-12
  • =8.5.8+dfsg-5
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade GitLab CE/EE to version 19.2.8 or later, 19.3.5 or later, or 19.4.2 or later to apply the official fix. These versions contain the remediation for the insufficient regular expression validation vulnerability. No other mitigations are indicated by the vendor advisory.

Description

A critical vulnerability in GitLab CE/EE versions from 19.2 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 allows unauthenticated users to execute arbitrary code on the GitLab server. This occurs due to insufficient validation of regular expressions in CI/CD configurations. The vulnerability has a CVSS score of 10.0 and public exploit code is available via Metasploit. GitLab has released fixes in versions 19.2.8, 19.3.5, and 19.4.2 to remediate this issue.

References

Community reviews

Loading reviews…