Skip to main content
VulnerabilityPublished Updated

CVE-2026-67325: GitPython · Command Injection via git long-option prefix abbreviation bypass of CVE-2026-42215 blocklist

Affects snakemakeSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2026-67325· High 8.7

Not known to be exploited · CVSS 8.7 High : upgrade to 9.23.1_1 soon.

Data as of 26 Oct 2026, 19:31 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 9.23.1_1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 1 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    CISA SSVC: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by VulnCheck

    , 3 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. CISA SSVC assessment

    proof of concept public

    , 4 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA SSVC, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade snakemake to 9.23.1_1.

Affected software

ProductAffectedFixed in
Homebrewsnakemakepkg:brew/snakemakeOther threatsAffected
  • >=5.5.3 <9.23.1_1
Fixed in
  • 9.23.1_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in GitPython version 9.23.1_1 that addresses this vulnerability by properly handling git's long-option prefix abbreviations in the unsafe options blocklist. Users should upgrade to version 9.23.1_1 or later. Until patched, avoid passing untrusted or attacker-controlled keyword argument keys to GitPython clone, fetch, pull, or push operations with 'allow_unsafe_options=False'.

Description

GitPython versions from 5.5.3 up to but not including 9.23.1_1 contain a command injection vulnerability (CVE-2026-67325) due to incomplete blocking of unsafe git options. The vulnerability arises because the fix for a previous issue (CVE-2026-42215) only blocks exact matches of dangerous git options but does not account for git's acceptance of unambiguous long-option prefix abbreviations. This allows attackers to bypass the blocklist by using abbreviated option keys that are translated into dangerous git commands, leading to remote code execution when attacker-controlled keys are passed to GitPython clone, fetch, pull, or push operations. A fix is available in version 9.23.1_1.

References

Community reviews

Loading reviews…