CVE-2026-67325: GitPython · Command Injection via git long-option prefix abbreviation bypass of CVE-2026-42215 blocklist
Affects nbdimeSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 8.7 High : upgrade to 4.0.4_4 soon.
Data as of 26 Oct 2026, 17:30 UTC
- EPSS
- 2.2% chance of exploitation in 30 days – higher than 82% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.0.4_4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
t = 0 is the CVE’s publication on cve.org
Disclosed: evidence found.
CVE published 1 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: evidence found.
CISA SSVC: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
Timeline
CVE ID reserved
by VulnCheck
, 3 days before disclosure
CVE published
on cve.org
, t = 0
CISA SSVC assessment
proof of concept public
, 4 days after disclosure
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA SSVC, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade nbdime to 4.0.4_4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewnbdimepkg:brew/nbdimeOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in GitPython version 4.0.4_4. Users should upgrade to this version or later to remediate the vulnerability. The vendor advisory confirms the patch availability. Until upgrading, avoid passing untrusted or attacker-controlled keyword argument keys to GitPython methods that invoke git commands. The vulnerability is in the defense-in-depth control 'allow_unsafe_options=False' which is bypassed by this issue; using 'allow_unsafe_options=True' is out of scope and does not mitigate this vulnerability.
Description
GitPython versions from 1.1.0 up to but not including 4.0.4_4 contain a command injection vulnerability (CVE-2026-67325) due to incomplete blocking of unsafe git options. The vulnerability arises because the fix for a previous issue (CVE-2026-42215) only blocked exact matches of dangerous options but did not account for git's acceptance of unambiguous long-option prefix abbreviations. This allows attackers controlling keyword argument keys to bypass the blocklist and execute arbitrary commands during clone, fetch, pull, or push operations. A fix is available in version 4.0.4_4.
References
- github.com/gitpython-developers/GitPython/security/advisories/GHSA-2f96-g7mh-g2hx (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-67325 (opens in a new tab)
- github.com/gitpython-developers/GitPython/pull/2161 (opens in a new tab)
- github.com/gitpython-developers/GitPython/commit/56806080c1348749b07daa4a2024ce47b3cad285 (opens in a new tab)
- github.com/gitpython-developers/GitPython (opens in a new tab)
- github.com/gitpython-developers/GitPython/releases/tag/3.1.51 (opens in a new tab)
- vulncheck.com/advisories/gitpython-before-command-injection-via-option-prefix-abbreviation (opens in a new tab)