Skip to main content
VulnerabilityPublished Updated

CVE-2026-40258: gramps-webapi · Zip Slip Path Traversal in Media Archive Import

Affects gramps-webapiSource GCVE Database

0
Authoritative record:CVE-2026-40258· Critical 9.1

Not known to be exploited · CVSS 9.1 Critical : upgrade to 3.11.1 as a priority.

Data as of 27 Oct 2026, 17:30 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.11.1
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gramps-webapi to 3.11.1.

Affected software

ProductAffectedFixed in
PyPIgramps-webapiAffected
  • >=1.6.0 <3.11.1
Fixed in
  • 3.11.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in gramps-webapi version 3.11.1 that validates ZIP entry paths before extraction to prevent directory traversal. Users should upgrade to version 3.11.1 or later to remediate this vulnerability. No additional mitigation is required if the patch is applied.

Description

A critical path traversal vulnerability (Zip Slip) exists in the media archive import feature of gramps-webapi. Authenticated users with owner-level privileges can craft malicious ZIP files with directory-traversal filenames to write arbitrary files outside the intended extraction directory on the server. This can lead to cross-tree data corruption or overwriting of important files depending on the deployment configuration. The vulnerability affects versions from 1.6.0 up to but not including 3.11.1. A fix is available in version 3.11.1 that validates ZIP entry paths before extraction.

References

Community reviews

Loading reviews…