Skip to main content
VulnerabilityPublished

haproxy regression

Affects haproxySource GCVE Database

0

Mentioned vulnerabilities

Severity
High

Rated High by Threat Radar's AI analysis

Patch
Available – fixed in 2.4.30-0ubuntu0.22.04.4

Data as of 6 Nov 2026, 02:06 UTC

What to do

Upgrade the Ubuntu haproxy package to 2.4.30-0ubuntu0.22.04.4.

Affected software

ProductAffectedFixed in
Ubuntu 22.04 LTShaproxypkg:deb/ubuntu/haproxy?arch=source&distro=jammyOther threatsAffected
  • <2.4.30-0ubuntu0.22.04.4
Fixed in
  • 2.4.30-0ubuntu0.22.04.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied. The issue is fixed in HAProxy version 2.4.30-0ubuntu0.22.04.4. Users running affected versions should upgrade to this fixed version to resolve the regression and prevent denial of service.

Description

A regression in HAProxy on Ubuntu 22.04 LTS caused by an update fixed in USN-8972-1 led to improper handling of certain chunked HTTP/1.1 requests and truncated HTTP/2 PING frames. These issues could allow a remote attacker to cause HAProxy to consume excessive CPU resources, resulting in denial of service. The problem has been fixed in version 2.4.30-0ubuntu0.22.04.4.

References

Community reviews

Loading reviews…