CVE-2026-59939: httplib2 · Decompression Bomb Denial of Service via Unbounded gzip/deflate Response Handling
Affects mcp-google-sheetsSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 0.6.3_4 soon.
Data as of 1 Nov 2026, 01:52 UTC
- Patch
- Available – fixed in 0.6.3_4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade mcp-google-sheets to 0.6.3_4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewmcp-google-sheetspkg:brew/mcp-google-sheetsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in httplib2 version 0.6.3_4 that addresses this vulnerability. Users should upgrade to version 0.6.3_4 or later to mitigate the risk. Until patched, avoid making HTTP requests with httplib2 to untrusted or attacker-controlled servers. There is no vendor advisory indicating alternative mitigations or that no action is required.
Description
The httplib2 HTTP client library is vulnerable to a decompression bomb denial of service (DoS) attack via unbounded gzip or deflate response handling. A malicious HTTP server can send a small compressed payload that decompresses to a very large size in memory, causing the client process to run out of memory or crash. This affects any application using httplib2.Http().request() with untrusted HTTP endpoints. The vulnerability arises because the library decompresses entire gzip or deflate payloads without size limits or checks. A fix is available in version 0.6.3_4.
References
- github.com/httplib2/httplib2/security/advisories/GHSA-j5g9-f88f-gfj3 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-59939 (opens in a new tab)
- github.com/httplib2/httplib2/commit/87581ad6cf752fe3da2090c59058261d2d00a427 (opens in a new tab)
- github.com/httplib2/httplib2 (opens in a new tab)
- github.com/httplib2/httplib2/releases/tag/v0.32.0 (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/httplib2/PYSEC-2026-3444.yaml (opens in a new tab)
- lists.debian.org/debian-lts-announce/2026/08/msg00039.html (opens in a new tab)