CVE-2026-59886: pyasn1 · Uncontrolled resource consumption when converting decoded REAL values
Affects mcp-google-sheetsSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 0.6.3_4 soon.
Data as of 1 Nov 2026, 01:51 UTC
- Patch
- Available – fixed in 0.6.3_4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade mcp-google-sheets to 0.6.3_4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewmcp-google-sheetspkg:brew/mcp-google-sheetsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade pyasn1 to version 0.6.3_4 or later, where the vulnerability is fixed. If upgrading is not immediately possible, avoid converting, printing, or comparing decoded Real objects from untrusted sources; instead, inspect the raw (mantissa, base, exponent) tuple to prevent triggering the float conversion. No other mitigations are specified.
Description
A vulnerability in the pyasn1 library's handling of ASN.1 REAL values allows an attacker to cause excessive CPU and memory consumption by crafting BER/CER/DER-encoded REAL values with very large exponents. This leads to denial of service when the decoded REAL values are converted to floats or used in operations like printing, logging, or comparison. The issue affects pyasn1 versions from 0.5.1 up to but not including 0.6.3_4 and is fixed in version 0.6.3_4.
References
- github.com/pyasn1/pyasn1/security/advisories/GHSA-hm4w-wwcw-mr6r (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-59886 (opens in a new tab)
- github.com/pyasn1/pyasn1/commit/e60c691cb91addb8fcefa2f537e85ede6fb1e886 (opens in a new tab)
- github.com/pyasn1/pyasn1 (opens in a new tab)
- github.com/pyasn1/pyasn1/releases/tag/v0.6.4 (opens in a new tab)