CVE-2026-59884: Mcp google sheets · pyasn1 BER/CER/DER decoder denial of service via unbounded long-form tag IDs
Affects mcp-google-sheetsSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 0.6.3_4 soon.
Data as of 1 Nov 2026, 01:52 UTC
- Patch
- Available – fixed in 0.6.3_4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade mcp-google-sheets to 0.6.3_4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewmcp-google-sheetspkg:brew/mcp-google-sheetsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in pyasn1 version 0.6.3_4 that limits long-form tag IDs to 20 octets and rejects oversized tags with a PyAsn1Error. Users should upgrade to version 0.6.3_4 or later. As a workaround, applications can bound the size of untrusted input passed to decode() to prevent excessive resource consumption. No other mitigations are indicated.
Description
A denial of service vulnerability exists in the pyasn1 BER/CER/DER decoder due to unbounded long-form tag IDs. The decoder accumulates continuation octets without an upper limit, allowing crafted inputs to cause excessive CPU consumption. On Python 3.11 and later, this can also trigger an unhandled ValueError during error message formatting, potentially bypassing error handling. The issue affects decoding of untrusted BER/CER/DER inputs in pyasn1 versions from 0.5.1 up to but not including 0.6.3_4. The vulnerability is fixed in version 0.6.3_4 by limiting tag ID length and hardening error handling.
References
- github.com/pyasn1/pyasn1/security/advisories/GHSA-m4p7-r5rc-7g4j (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-59884 (opens in a new tab)
- github.com/pyasn1/pyasn1/commit/628e36ecbb5277a3f01572ce418ef54271b165a5 (opens in a new tab)
- github.com/pyasn1/pyasn1 (opens in a new tab)
- github.com/pyasn1/pyasn1/releases/tag/v0.6.4 (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/pyasn1/PYSEC-2026-3455.yaml (opens in a new tab)