CVE-2026-56372: ImageMagick before 7.1.2-19 contains a heap buffer overflow vulnerability in the magnify operation
Affects ImageMagickSource GCVE Database
Not known to be exploited · CVSS 3.3 Low : upgrade to 7.1.2-19 when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 26% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.1.2-19
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 11 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade imagemagick/ImageMagick to 7.1.2-19.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubimagemagick/ImageMagickpkg:github/imagemagick/ImageMagickOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, avoid processing untrusted input with the magnify operation or restrict usage to trusted sources only.
Description
ImageMagick before 7.1.2-19 contains a heap buffer overflow vulnerability in the magnify operation that allows attackers to read out of bounds memory. An unrecognized magnify:method value triggers an out of bounds read, potentially exposing sensitive information or causing denial of service.