Skip to main content
VulnerabilityPublished Updated

CVE-2026-33006: httpd:2.4 security, bug fix, and enhancement update

Affects httpdSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-33006· Medium 4.8

Not known to be exploited · CVSS 4.8 Medium · fixed in 2.4.37-65.module_el8.10.0+4332+2bef2e0d.13 : update httpd when convenient.

Data as of 30 Oct 2026, 16:06 UTC

CVSS 3.1 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.4.37-65.module_el8.10.0+4332+2bef2e0d.13, 1.15.7-10.module_el8.10.0+4233+8b7d9181.7, 1.15.7-10.module_el8.10.0+4270+e5f13fdb.7 +2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
AlmaLinux 8httpdAffected
  • <2.4.37-65.module_el8.10.0+4332+2bef2e0d.13
Fixed in
  • 2.4.37-65.module_el8.10.0+4332+2bef2e0d.13
AlmaLinux 8httpd-develAffected
  • <2.4.37-65.module_el8.10.0+4332+2bef2e0d.13
Fixed in
  • 2.4.37-65.module_el8.10.0+4332+2bef2e0d.13
AlmaLinux 8httpd-filesystemAffected
  • <2.4.37-65.module_el8.10.0+4332+2bef2e0d.13
Fixed in
  • 2.4.37-65.module_el8.10.0+4332+2bef2e0d.13
AlmaLinux 8httpd-manualAffected
  • <2.4.37-65.module_el8.10.0+4332+2bef2e0d.13
Fixed in
  • 2.4.37-65.module_el8.10.0+4332+2bef2e0d.13
AlmaLinux 8httpd-toolsAffected
  • <2.4.37-65.module_el8.10.0+4332+2bef2e0d.13
Fixed in
  • 2.4.37-65.module_el8.10.0+4332+2bef2e0d.13
AlmaLinux 8mod_http2Affected
  • <1.15.7-10.module_el8.10.0+4233+8b7d9181.7
Fixed in
  • 1.15.7-10.module_el8.10.0+4233+8b7d9181.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available that addresses all listed vulnerabilities. Users should apply the updated httpd packages fixed in versions 2.4.37-65.module_el8.10.0+4332+2bef2e0d.13 and related fixed versions as soon as possible. Refer to the vendor advisory at https://access.redhat.com/errata/RHSA-2026:92616 and https://access.redhat.com/articles/11258 for detailed update instructions. No additional mitigation actions are required beyond applying the official patches.

Description

Multiple security vulnerabilities have been identified in the Apache HTTP Server (httpd) 2.4 and related modules, including authentication bypasses, denial of service, HTTP response smuggling, arbitrary code execution, and unauthorized connections. These issues affect various modules such as mod_auth_digest, mod_proxy_uwsgi, mod_dav_fs, mod_vhost_alias, and others. A security update has been released to address these vulnerabilities along with bug fixes and enhancements.

References

Community reviews

Loading reviews…