Skip to main content
VulnerabilityPublished Updated

CVE-2026-88806: libX11 security update

Affects libX11Source GCVE Database

0
Compare
Authoritative record:CVE-2026-88806· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 1.8.12-1.el9_8.1 soon.

Data as of 30 Oct 2026, 02:00 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.8.12-1.el9_8.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade the AlmaLinux to 1.8.12-1.el9_8.1.

Affected software

ProductAffectedFixed in
AlmaLinux 9libX11Affected
  • <1.8.12-1.el9_8.1
Fixed in
  • 1.8.12-1.el9_8.1
AlmaLinux 9libX11-commonAffected
  • <1.8.12-1.el9_8.1
Fixed in
  • 1.8.12-1.el9_8.1
AlmaLinux 9libX11-develAffected
  • <1.8.12-1.el9_8.1
Fixed in
  • 1.8.12-1.el9_8.1
AlmaLinux 9libX11-xcbAffected
  • <1.8.12-1.el9_8.1
Fixed in
  • 1.8.12-1.el9_8.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing this vulnerability is available and should be applied promptly. Red Hat has released fixed libX11 packages at version 1.8.12-1.el9_8.1 for Red Hat Enterprise Linux 9.8 Extended Update Support and related variants. Users should follow the official Red Hat guidance to update affected systems. No additional mitigation actions are specified beyond applying the update.

Description

A heap-based buffer overflow vulnerability exists in the libX11 core X11 protocol client library, which can be triggered by a malicious X server. This vulnerability is identified as CVE-2026-88806 and affects libX11 versions prior to 1.8.12-1.el9_8.1. Red Hat has released an important security update to address this issue in Red Hat Enterprise Linux 9.8 Extended Update Support and related variants.

References

Community reviews

Loading reviews…