Skip to main content
VulnerabilityPublished Updated

CVE-2026-49261: Important · mariadb:10.11 security, bug fix, and enhancement update

Affects galeraSource GCVE Database

0
Compare
Authoritative record:CVE-2026-49261· Critical 10.0

Not known to be exploited · CVSS 10.0 Critical · fixed in 26.4.27-1.module_el9.8.0+315+b08bed7e : patch galera as a priority.

Data as of 30 Oct 2026, 02:00 UTC

CVSS 3.1 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 26.4.27-1.module_el9.8.0+315+b08bed7e, 26.4.27-1.module_el9.8.0+275+ff40c56f, 3:10.11.18-1.module_el9.8.0+275+ff40c56f +1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
AlmaLinux 9galeraAffected
  • <26.4.27-1.module_el9.8.0+315+b08bed7e
Fixed in
  • 26.4.27-1.module_el9.8.0+315+b08bed7e
AlmaLinux 9galeraAffected
  • <26.4.27-1.module_el9.8.0+275+ff40c56f
Fixed in
  • 26.4.27-1.module_el9.8.0+275+ff40c56f
AlmaLinux 9mariadbAffected
  • <3:10.11.18-1.module_el9.8.0+275+ff40c56f
Fixed in
  • 3:10.11.18-1.module_el9.8.0+275+ff40c56f
AlmaLinux 9mariadbAffected
  • <3:10.11.18-1.module_el9.8.0+315+b08bed7e.alma.1
Fixed in
  • 3:10.11.18-1.module_el9.8.0+315+b08bed7e.alma.1
AlmaLinux 9mariadb-backupAffected
  • <3:10.11.18-1.module_el9.8.0+315+b08bed7e.alma.1
Fixed in
  • 3:10.11.18-1.module_el9.8.0+315+b08bed7e.alma.1
AlmaLinux 9mariadb-backupAffected
  • <3:10.11.18-1.module_el9.8.0+275+ff40c56f
Fixed in
  • 3:10.11.18-1.module_el9.8.0+275+ff40c56f

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied immediately. Red Hat has released updated packages rebasing Galera to 26.4.27 and MariaDB to 10.11.18 that fix this vulnerability. Users should follow the update instructions provided by Red Hat in their advisory (https://access.redhat.com/articles/11258) to remediate the issue. No additional mitigation steps are indicated beyond applying the official update.

Description

MariaDB Server versions prior to 10.11.18 and Galera versions prior to 26.4.27 contain a security vulnerability (CVE-2026-49261) that allows arbitrary code execution via the wsrep_notify_cmd component. This vulnerability affects multi-user, multi-threaded SQL database servers compatible with MySQL. Red Hat has released updates rebasing Galera to 26.4.27 and MariaDB to 10.11.18 to address this issue. The update is rated as Important by Red Hat Product Security.

References

Community reviews

Loading reviews…