CVE-2026-93543: libXi security update
Affects libXiSource GCVE Database
Not known to be exploited · CVSS 7.4 High : upgrade to 1.7.10-8.el9_8.1 soon.
Data as of 30 Oct 2026, 02:01 UTC
- Patch
- Available – fixed in 1.7.10-8.el9_8.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 24 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade the AlmaLinux to 1.7.10-8.el9_8.1.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AlmaLinux 9libXi | Affected
| Fixed in
|
| AlmaLinux 9libXi-devel | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A security update fixing this vulnerability is available in libXi version 1.7.10-8.el9_8.1 for Red Hat Enterprise Linux 9 and related variants. Users should apply this update promptly to remediate the issue. Refer to the Red Hat advisory RHSA-2026:91056 and the update instructions at https://access.redhat.com/articles/11258 for detailed guidance.
Description
A denial of service vulnerability exists in the X.Org X11 libXi runtime library due to an out-of-bounds read in the XI2 class parser. This issue is tracked as CVE-2026-93543 and affects libXi versions prior to 1.7.10-8.el9_8.1. The vulnerability has been rated with moderate severity by Red Hat. A security update fixing this issue is available for Red Hat Enterprise Linux 9 and related variants.