Skip to main content
VulnerabilityPublished Updated

CVE-2026-88807: libXrender security update

Affects libXrenderSource GCVE Database

0
Compare
Authoritative record:CVE-2026-88807· High 8.9

Not known to be exploited · CVSS 8.9 High : upgrade to 0.9.10-16.el9_8.2 soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 4.0 base score
8.9High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.9.10-16.el9_8.2
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade the AlmaLinux to 0.9.10-16.el9_8.2.

Affected software

ProductAffectedFixed in
AlmaLinux 9libXrenderAffected
  • <0.9.10-16.el9_8.2
Fixed in
  • 0.9.10-16.el9_8.2
AlmaLinux 9libXrender-develAffected
  • <0.9.10-16.el9_8.2
Fixed in
  • 0.9.10-16.el9_8.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing this vulnerability is available in libXrender version 0.9.10-16.el9_8.2 and later. Users should apply the official Red Hat update as described in the advisory (RHSA-2026:91057) to remediate this issue. No additional mitigation steps are indicated by the vendor.

Description

A heap overflow vulnerability in the libXrender library's RenderQueryPictFormats function allows for potential code injection. This issue affects versions of libXrender prior to 0.9.10-16.el9_8.2. Red Hat has released an important security update addressing this flaw in Red Hat Enterprise Linux 9 and related variants.

References

Community reviews

Loading reviews…