CVE-2025-8176: Important · mingw-libtiff security update
Affects mingw32-libtiffSource GCVE Database
Public exploit available · CVSS 4.8 Medium : upgrade to 4.0.9-3.el8_10 as a priority.
Data as of 4 Nov 2026, 18:43 UTC
- Patch
- Available – fixed in 4.0.9-3.el8_10
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 26 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade the AlmaLinux to 4.0.9-3.el8_10.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AlmaLinux 8mingw32-libtiff | Affected
| Fixed in
|
| AlmaLinux 8mingw32-libtiff-static | Affected
| Fixed in
|
| AlmaLinux 8mingw64-libtiff | Affected
| Fixed in
|
| AlmaLinux 8mingw64-libtiff-static | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A security update fixing this vulnerability is available in mingw32-libtiff version 4.0.9-3.el8_10. Users should apply this official patch to remediate the issue. No alternative mitigations meeting Red Hat's criteria are available.
Description
A use-after-free vulnerability (CVE-2025-8176) was discovered in the libtiff package's get_histogram function within the tiffmedian tool. This flaw allows a local attacker to trigger memory corruption by processing a specially crafted TIFF file, potentially leading to arbitrary code execution or denial of service. The vulnerability affects mingw32-libtiff versions prior to 4.0.9-3.el8_10. A security update fixing this issue is available from Red Hat.
References
- access.redhat.com/errata/RHSA-2025:19906 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2025-8176 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2025-9900 (opens in a new tab)
- bugzilla.redhat.com/2383598 (opens in a new tab)
- bugzilla.redhat.com/2392784 (opens in a new tab)
- errata.almalinux.org/8/ALSA-2025-19906.html (opens in a new tab)