CVE-2025-62229: tigervnc security update
Affects tigervncSource GCVE Database
Not known to be exploited · CVSS 7.3 High : upgrade to 1.15.0-8.el8_10 soon.
Data as of 4 Nov 2026, 18:43 UTC
- Patch
- Available – fixed in 1.15.0-8.el8_10
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade the AlmaLinux to 1.15.0-8.el8_10.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AlmaLinux 8tigervnc | Affected
| Fixed in
|
| AlmaLinux 8tigervnc-icons | Affected
| Fixed in
|
| AlmaLinux 8tigervnc-license | Affected
| Fixed in
|
| AlmaLinux 8tigervnc-selinux | Affected
| Fixed in
|
| AlmaLinux 8tigervnc-server | Affected
| Fixed in
|
| AlmaLinux 8tigervnc-server-minimal | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fixed version of TigerVNC is available in 1.15.0-8.el8_10. Users should apply this update to remediate the vulnerability. Refer to the Red Hat advisory RHSA-2025:19909 for detailed update instructions. No additional mitigation steps are indicated beyond applying the official patch.
Description
TigerVNC, a suite of VNC servers and clients, contains a use-after-free vulnerability in the xorg xmayland component related to XPresentNotify structure creation (CVE-2025-62229). This flaw could potentially lead to memory corruption. The vulnerability affects versions prior to 1.15.0-8.el8_10 and has been addressed in that release. The update is rated as having an Important security impact by Red Hat.
References
- access.redhat.com/errata/RHSA-2025:19909 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2025-62229 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2025-62230 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2025-62231 (opens in a new tab)
- bugzilla.redhat.com/2402649 (opens in a new tab)
- bugzilla.redhat.com/2402653 (opens in a new tab)
- bugzilla.redhat.com/2402660 (opens in a new tab)
- errata.almalinux.org/8/ALSA-2025-19909.html (opens in a new tab)