Skip to main content
VulnerabilityPublished Updated

CVE-2025-71436: raptor2 security update

Affects raptor2Source GCVE Database

0
Compare
Authoritative record:CVE-2025-71436· High 7.1

Not known to be exploited · CVSS 7.1 High : upgrade to 2.0.15-18.el8_10 soon.

Data as of 4 Nov 2026, 18:01 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.0.15-18.el8_10
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade the AlmaLinux to 2.0.15-18.el8_10.

Affected software

ProductAffectedFixed in
AlmaLinux 8raptor2Affected
  • <2.0.15-18.el8_10
Fixed in
  • 2.0.15-18.el8_10
AlmaLinux 8raptor2-develAffected
  • <2.0.15-18.el8_10
Fixed in
  • 2.0.15-18.el8_10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the security update provided by Red Hat that fixes this vulnerability. The fixed version is 2.0.15-18.el8_10. Refer to Red Hat's advisory RHSA-2026:94519 for detailed update instructions.

Description

A heap-based buffer overflow vulnerability in raptor2's language tag handling can lead to arbitrary code execution. This issue affects versions of raptor2 prior to 2.0.15-18.el8_10. A security update fixing this vulnerability is available from Red Hat.

References

Community reviews

Loading reviews…