Skip to main content
VulnerabilityPublished Updated

CVE-2026-114148: Important · .NET 10.0 security, bug fix, and enhancement update

Affects aspnetcore-runtime-10.0Source GCVE Database

0
Compare
Authoritative record:CVE-2026-114148· High 7.8

Not known to be exploited · CVSS 7.8 High · fixed in 10.0.14-1.el8_10 : patch aspnetcore-runtime-10.0 soon.

Data as of 31 Oct 2026, 13:08 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (microsoft)CVSS 3.17.8
Patch
Available – fixed in 10.0.14-1.el8_10, 10.0.114-1.el8_10
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade the AlmaLinux to 10.0.14-1.el8_10 (aspnetcore-runtime-10.0 package, aspnetcore-runtime-dbg-10.0 package, aspnetcore-targeting-pack-10.0 package, dotnet-apphost-pack-10.0 package, dotnet-hostfxr-10.0 package, dotnet-runtime-10.0 package, dotnet-runtime-dbg-10.0 package, dotnet-targeting-pack-10.0 package) or 10.0.114-1.el8_10 (dotnet-sdk-10.0 package, dotnet-sdk-10.0-source-built-artifacts package, dotnet-sdk-aot-10.0 package, dotnet-sdk-dbg-10.0 package, dotnet-templates-10.0 package).

Affected software

ProductAffectedFixed in
AlmaLinux 8aspnetcore-runtime-10.0Affected
  • <10.0.14-1.el8_10
Fixed in
  • 10.0.14-1.el8_10
AlmaLinux 8aspnetcore-runtime-dbg-10.0Affected
  • <10.0.14-1.el8_10
Fixed in
  • 10.0.14-1.el8_10
AlmaLinux 8aspnetcore-targeting-pack-10.0Affected
  • <10.0.14-1.el8_10
Fixed in
  • 10.0.14-1.el8_10
AlmaLinux 8dotnet-apphost-pack-10.0Affected
  • <10.0.14-1.el8_10
Fixed in
  • 10.0.14-1.el8_10
AlmaLinux 8dotnet-hostfxr-10.0Affected
  • <10.0.14-1.el8_10
Fixed in
  • 10.0.14-1.el8_10
AlmaLinux 8dotnet-runtime-10.0Affected
  • <10.0.14-1.el8_10
Fixed in
  • 10.0.14-1.el8_10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied to affected systems. Red Hat has released updated packages: SDK 10.0.114 and runtime 10.0.14, which fix the elevation of privilege vulnerability CVE-2026-114148. Users should update to these versions or later to remediate the issue. No additional mitigation steps are specified or required beyond applying the official update.

Description

.NET 10.0 for Red Hat Enterprise Linux contains an elevation of privilege vulnerability in ASP.NET Core identified as CVE-2026-114148. This security issue is addressed in updated SDK version 10.0.114 and runtime version 10.0.14. The vulnerability affects multiple .NET versions including 8.0, 9.0, 10.0, and 11.0. Red Hat has released patches to fix this important security flaw.

References

Community reviews

Loading reviews…