Skip to main content
VulnerabilityPublished Updated

CVE-2026-102010: gcc-toolset-15-gcc security update

Affects gcc-toolset-15-gccSource GCVE Database

0
Compare
Authoritative record:CVE-2026-102010· High 7.0

Not known to be exploited · CVSS 7.0 High : upgrade to 15.2.1-7.2.el8_10 soon.

Data as of 30 Oct 2026, 16:06 UTC

CVSS 3.1 base score
7.0High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (redhat)CVSS 3.17.0
Patch
Available – fixed in 15.2.1-7.2.el8_10
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade the AlmaLinux to 15.2.1-7.2.el8_10.

Affected software

ProductAffectedFixed in
AlmaLinux 8gcc-toolset-15-gccAffected
  • <15.2.1-7.2.el8_10
Fixed in
  • 15.2.1-7.2.el8_10
AlmaLinux 8gcc-toolset-15-gcc-c++Affected
  • <15.2.1-7.2.el8_10
Fixed in
  • 15.2.1-7.2.el8_10
AlmaLinux 8gcc-toolset-15-gcc-gfortranAffected
  • <15.2.1-7.2.el8_10
Fixed in
  • 15.2.1-7.2.el8_10
AlmaLinux 8gcc-toolset-15-gcc-plugin-annobinAffected
  • <15.2.1-7.2.el8_10
Fixed in
  • 15.2.1-7.2.el8_10
AlmaLinux 8gcc-toolset-15-gcc-plugin-develAffected
  • <15.2.1-7.2.el8_10
Fixed in
  • 15.2.1-7.2.el8_10
AlmaLinux 8gcc-toolset-15-libasan-develAffected
  • <15.2.1-7.2.el8_10
Fixed in
  • 15.2.1-7.2.el8_10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied by upgrading to gcc-toolset-15-gcc version 15.2.1-7.2.el8_10 or later. Refer to the Red Hat advisory RHSA-2026:90915 for detailed update instructions. No additional mitigation steps are indicated.

Description

A use-after-free vulnerability in the binary heap erase_if function of gcc-toolset-15-gcc (GNU Compiler Collection version 15) can lead to a denial of service condition. This issue is addressed in version 15.2.1-7.2.el8_10 of the package. The vulnerability has been rated as Moderate severity by Red Hat.

References

Community reviews

Loading reviews…