CVE-2026-111943: opentelemetry-collector security update
Affects opentelemetry-collectorSource GCVE Database
Not known to be exploited · CVSS 6.8 Medium : upgrade to 0.158.0-2.el10_2 when convenient.
Data as of 4 Nov 2026, 20:35 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 6.8 |
|---|
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.158.0-2.el10_2
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 21 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade the AlmaLinux opentelemetry-collector package to 0.158.0-2.el10_2.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AlmaLinux 10opentelemetry-collector | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A security update is available and should be applied to affected systems. Red Hat has released version 0.158.0-2.el10_2 of the opentelemetry-collector package which addresses these vulnerabilities. Users should follow Red Hat's official guidance to update their installations accordingly. No additional mitigation steps are indicated beyond applying the update.
Description
A security update for the opentelemetry-collector addresses multiple vulnerabilities in the underlying Go components used by the Red Hat build. Among these is CVE-2026-111943, a vulnerability in the crypto/x509 package that allows man-in-the-middle attacks via untrusted intermediate certificates. The update fixes this and several denial of service issues in other Go packages. The vulnerability is rated as Important by Red Hat and affects versions of opentelemetry-collector prior to 0.158.0-2.el10_2.
References
- access.redhat.com/errata/RHSA-2026:93596 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-111943 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-78667 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-78669 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-94440 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-97031 (opens in a new tab)
- bugzilla.redhat.com/2548334 (opens in a new tab)
- bugzilla.redhat.com/2548336 (opens in a new tab)
- bugzilla.redhat.com/2548341 (opens in a new tab)
- bugzilla.redhat.com/2548344 (opens in a new tab)
- bugzilla.redhat.com/2556068 (opens in a new tab)
- errata.almalinux.org/10/ALSA-2026-93596.html (opens in a new tab)