CVE-2025-59375: expat security update
Affects expatSource GCVE Database
Public exploit available · CVSS 7.5 High : upgrade to 2.7.1-1.el10_0.3 as a priority.
Data as of 4 Nov 2026, 18:43 UTC
- Patch
- Available – fixed in 2.7.1-1.el10_0.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:H/RL:T/RC:CExploitation evidence
Disclosed: evidence found.
CVE published 15 Sep 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade the AlmaLinux to 2.7.1-1.el10_0.3.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AlmaLinux 10expat | Affected
| Fixed in
|
| AlmaLinux 10expat-devel | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fixed version of Expat is available (2.7.1-1.el10_0.3). Users and administrators should apply the update provided by Red Hat to remediate this vulnerability. No additional mitigation steps are indicated by the vendor advisory.
Description
A security vulnerability (CVE-2025-59375) in the Expat C library allows attackers to trigger large dynamic memory allocations by submitting a small XML document for parsing. This issue affects versions of Expat prior to 2.7.1-1.el10_0.3. The vulnerability has been rated as Important by Red Hat and is addressed in the fixed version 2.7.1-1.el10_0.3.