CVE-2026-12080: Important · qemu-kvm security, bug fix, and enhancement update
Affects qemu-guest-agentSource GCVE Database
Not known to be exploited · CVSS 7.3 High : upgrade to 17:10.1.0-17.el9_8.9.alma.1 soon.
Data as of 4 Nov 2026, 18:02 UTC
Thin evidence
One scorer or none| CNA (redhat) | CVSS 3.1 | 7.3 |
|---|
- Patch
- Available – fixed in 17:10.1.0-17.el9_8.9.alma.1
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 20 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade the AlmaLinux to 17:10.1.0-17.el9_8.9.alma.1.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AlmaLinux 9qemu-guest-agent | Affected
| Fixed in
|
| AlmaLinux 9qemu-img | Affected
| Fixed in
|
| AlmaLinux 9qemu-kvm | Affected
| Fixed in
|
| AlmaLinux 9qemu-kvm-audio-pa | Affected
| Fixed in
|
| AlmaLinux 9qemu-kvm-block-blkio | Affected
| Fixed in
|
| AlmaLinux 9qemu-kvm-block-curl | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official patch by updating qemu-guest-agent to version 17:10.1.0-17.el9_8.9.alma.1 or later. This update resolves the local privilege escalation vulnerability. No additional mitigation steps are indicated by the vendor advisory.
Description
A local privilege escalation vulnerability exists in the qemu-guest-agent component of qemu-kvm due to a symlink attack in guest-ssh-add-authorized-keys (CVE-2026-12080). This issue allows a local attacker within the guest to escalate privileges. The vulnerability affects versions of qemu-guest-agent prior to 17:10.1.0-17.el9_8.9.alma.1. A patch is available in this fixed version. Additional bug fixes and enhancements are included in the update.