CVE-2026-111943: opentelemetry-collector security update
Affects opentelemetry-collectorSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 6.8 Medium : upgrade to 0.158.0-2.el9_8 when convenient.
Data as of 4 Nov 2026, 20:35 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 6.8 |
|---|
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.158.0-2.el9_8
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 21 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade the AlmaLinux opentelemetry-collector package to 0.158.0-2.el9_8.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AlmaLinux 9opentelemetry-collector | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A security update is available and should be applied to remediate these vulnerabilities. The fixed version is 0.158.0-2.el9_8. Users should upgrade to this version or later to address these issues. No additional mitigations are indicated by the vendor advisory.
Description
A security update for the opentelemetry-collector addresses multiple vulnerabilities in the underlying Golang components used by the Red Hat build of OpenTelemetry. Among these, CVE-2026-111943 is a vulnerability in the crypto/x509 package that allows man-in-the-middle attacks via untrusted intermediate certificates. Other fixes address denial of service issues in HTTP handling and TLS. The affected versions are all prior to 0.158.0-2.el9_8, which contains the fix.
References
- access.redhat.com/errata/RHSA-2026:93617 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-111943 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-78667 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-78669 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-94440 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-97031 (opens in a new tab)
- bugzilla.redhat.com/2548334 (opens in a new tab)
- bugzilla.redhat.com/2548336 (opens in a new tab)
- bugzilla.redhat.com/2548341 (opens in a new tab)
- bugzilla.redhat.com/2548344 (opens in a new tab)
- bugzilla.redhat.com/2556068 (opens in a new tab)
- errata.almalinux.org/9/ALSA-2026-93617.html (opens in a new tab)