Skip to main content
VulnerabilityPublished Updated

CVE-2025-10729: qt6-qtsvg security update

Affects qt6-qtsvgSource GCVE Database

0
Compare
Authoritative record:CVE-2025-10729· Critical 9.4

Not known to be exploited · CVSS 9.4 Critical : upgrade to 6.8.1-1.el10_0.1 as a priority.

Data as of 4 Nov 2026, 18:41 UTC

CVSS 4.0 base score
9.4Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 6.8.1-1.el10_0.1
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/S:P/RE:H/U:Red

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade the AlmaLinux to 6.8.1-1.el10_0.1.

Affected software

ProductAffectedFixed in
AlmaLinux 10qt6-qtsvgAffected
  • <6.8.1-1.el10_0.1
Fixed in
  • 6.8.1-1.el10_0.1
AlmaLinux 10qt6-qtsvg-develAffected
  • <6.8.1-1.el10_0.1
Fixed in
  • 6.8.1-1.el10_0.1
AlmaLinux 10qt6-qtsvg-examplesAffected
  • <6.8.1-1.el10_0.1
Fixed in
  • 6.8.1-1.el10_0.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version 6.8.1-1.el10_0.1 of qt6-qtsvg is available and should be applied to remediate this vulnerability. Users should update affected systems to this version or later as per the Red Hat advisory. No additional mitigation steps are indicated by the vendor.

Description

A use-after-free vulnerability (CVE-2025-10729) exists in the Qt SVG module (qt6-qtsvg), which is responsible for rendering and displaying SVG graphics. This vulnerability affects versions prior to 6.8.1-1.el10_0.1. The issue has been addressed in version 6.8.1-1.el10_0.1. The vulnerability is rated as Important by Red Hat Product Security. No known exploits in the wild have been reported.

References

Community reviews

Loading reviews…