Barn2 Plugins · Cross-site Scripting
Source GCVE Database
Not known to be exploited · CVSS 6.5 Medium : upgrade to 1.4.15 when convenient.
Data as of 3 Nov 2026, 19:43 UTC
Thin evidence
One scorer or none| CNA (Patchstack) | CVSS 3.1 | 6.5 |
|---|
- Patch
- Available – fixed in 1.4.15
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade Posts Table with Search & Sort to 1.4.15.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Posts Table with Search & Sortposts-data-table | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, users should exercise caution with input handling and consider applying any available workarounds or mitigations recommended by the vendor.
Description
A stored cross-site scripting (XSS) vulnerability exists in Barn2 Plugins Posts Table with Search & Sort up to version 1.4.14. This flaw allows improper neutralization of input during web page generation, potentially enabling attackers to inject malicious scripts that execute in users' browsers. The vulnerability has a CVSS score of 6.5, indicating a medium severity level.