Skip to main content
VulnerabilityPublished

CVE-2026-15723: GitLab · Improper Neutralization of Special Elements Used

Affects gitlabSource GCVE Database

0
Compare
Authoritative record:CVE-2026-15723· High 8.2

Not known to be exploited · CVSS 8.2 High · fixed in 19.5.1 : patch gitlab soon.

Data as of 29 Oct 2026, 14:41 UTC

CVSS 3.1 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitLab)CVSS 3.18.2
EPSS
0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 19.5.1, 19.4.3, 19.3.6
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade gitlab to 19.5.1, 19.4.3 or 19.3.6.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=10.1.0 <19.3.6
  • >=19.4.0 <19.4.3
  • >=19.5.0 <19.5.1
Fixed in
  • 19.3.6
  • 19.4.3
  • 19.5.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade GitLab to version 19.3.6, 19.4.3, or 19.5.1 or later where this vulnerability is fixed. Since a patch is available and the issue is remediated in these versions, applying the official update is the recommended mitigation.

Description

GitLab versions from 10.1 up to but not including 19.3.6, 19.4 up to 19.4.3, and 19.5 up to 19.5.1 contain an LDAP injection vulnerability. This flaw occurs when OmniAuth SAML and LDAP auto-linking are both enabled, allowing an authenticated user to take over an existing LDAP-backed account without interaction from the targeted user due to improper input sanitization in the LDAP email lookup during OmniAuth identity linking. The issue has been fixed in GitLab versions 19.3.6, 19.4.3, and 19.5.1.

References

Community reviews

Loading reviews…