Skip to main content
VulnerabilityPublished

CVE-2026-12664: GitLab · Incorrect Authorization

Affects gitlabSource GCVE Database

0
Compare
Authoritative record:CVE-2026-12664· Medium 6.8

Not known to be exploited · CVSS 6.8 Medium · fixed in 19.5.1 : update gitlab when convenient.

Data as of 29 Oct 2026, 14:41 UTC

CVSS 3.1 base score
6.8Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitLab)CVSS 3.16.8
EPSS
0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 19.5.1, 19.4.3, 19.3.6
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade gitlab to 19.5.1, 19.4.3 or 19.3.6.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=18.2.0 <19.3.6
  • >=19.4.0 <19.4.3
  • >=19.5.0 <19.5.1
Fixed in
  • 19.3.6
  • 19.4.3
  • 19.5.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading GitLab CE/EE to versions 19.3.6, 19.4.3, or 19.5.1 or later. These versions contain the fix that properly enforces token scope restrictions on the affected GraphQL field. No additional mitigation steps are indicated.

Description

GitLab CE/EE versions from 18.2 up to but not including 19.3.6, 19.4 up to 19.4.3, and 19.5 up to 19.5.1 contain an authorization flaw. An authenticated user with a read_api-scoped token could bypass token restrictions to retrieve a project's incoming email address and create work items due to insufficient scope enforcement on a GraphQL field. This issue has been fixed in versions 19.3.6, 19.4.3, and 19.5.1.

References

Community reviews

Loading reviews…