Skip to main content
VulnerabilityPublished

CVE-2026-112378: GitLab · Use of Less Trusted Source

Affects gitlabSource GCVE Database

0
Compare
Authoritative record:CVE-2026-112378· Medium 4.3

Not known to be exploited · CVSS 4.3 Medium · fixed in 19.5.1 : update gitlab when convenient.

Data as of 29 Oct 2026, 14:41 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 19.5.1, 19.4.3, 19.3.6
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade gitlab to 19.5.1, 19.4.3 or 19.3.6.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=17.8.0 <19.3.6
  • >=19.4.0 <19.4.3
  • >=19.5.0 <19.5.1
Fixed in
  • 19.3.6
  • 19.4.3
  • 19.5.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade affected GitLab EE instances to version 19.3.6, 19.4.3, or 19.5.1 or later to apply the official fix. Since a patch is available and the vulnerability is fixed in these versions, applying the update fully mitigates the issue.

Description

A vulnerability in GitLab Enterprise Edition versions from 17.8 up to but not including 19.3.6, 19.4 up to but not including 19.4.3, and 19.5 up to but not including 19.5.1 allowed authenticated users to access paid AI features without a valid subscription. This was due to insufficient server-side validation in billing eligibility checks. The issue has been fixed in versions 19.3.6, 19.4.3, and 19.5.1.

References

Community reviews

Loading reviews…