Skip to main content
VulnerabilityPublished

CVE-2026-14288: GitLab · Use of Incorrectly-Resolved Name or Reference

Affects gitlabSource GCVE Database

0
Compare
Authoritative record:CVE-2026-14288· Low 3.1

Not known to be exploited · CVSS 3.1 Low · fixed in 19.5.1 : update gitlab when convenient.

Data as of 29 Oct 2026, 14:41 UTC

CVSS 3.1 base score
3.1Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 19.5.1, 19.4.3, 19.3.6
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade gitlab to 19.5.1, 19.4.3 or 19.3.6.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=17.4.0 <19.3.6
  • >=19.4.0 <19.4.3
  • >=19.5.0 <19.5.1
Fixed in
  • 19.3.6
  • 19.4.3
  • 19.5.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade GitLab Enterprise Edition to version 19.3.6, 19.4.3, or 19.5.1 or later where this issue is fixed. Since patches are available, applying the official fixes is the recommended remediation.

Description

A vulnerability in GitLab Enterprise Edition versions from 17.4 up to but not including 19.3.6, 19.4 up to but not including 19.4.3, and 19.5 up to but not including 19.5.1 could allow an authenticated user to bypass a required merge request approval policy on a protected branch. This occurs due to improper access control during approval rule synchronization. The issue has been fixed in versions 19.3.6, 19.4.3, and 19.5.1.

References

Community reviews

Loading reviews…