CVE-2025-43964: In LibRaw before 0.21.4, tag 0x412 processing in phase_one_correct in decoders/load_mfbacks.cpp does
Source GCVE Database
Not known to be exploited · CVSS 2.9 Low · fixed in 0.21.4 : update LibRaw when convenient.
Data as of 30 Oct 2026, 01:34 UTC
Thin evidence
One scorer or none| CNA (mitre) | CVSS 3.1 | 2.9 |
|---|
- Affects
- LibRaw before 0.21.4
- Patch
- Available – fixed in 0.21.4
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 20 Apr 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
AI-suggested
Upgrade to LibRaw version 0.21.4 or later where this issue is fixed. No other mitigation actions are indicated.
Description
A vulnerability in LibRaw versions before 0.21.4 involves improper enforcement of minimum values for parameters w0 and w1 during processing of tag 0x412 in the phase_one_correct function within decoders/load_mfbacks.cpp. This flaw may lead to a low-severity impact on availability.
References
- nvd.nist.gov/vuln/detail/CVE-2025-43964 (opens in a new tab)
- github.com/LibRaw/LibRaw/commit/a50dc3f1127d2e37a9b39f57ad9bb2ebb60f18c0 (opens in a new tab)
- github.com/LibRaw/LibRaw/compare/0.21.3...0.21.4 (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/04/msg00038.html (opens in a new tab)
- libraw.org/news/libraw-0-21-4-release (opens in a new tab)