CVE-2026-59739: zookeeper · Information Disclosure via SetWatches Reconnect Replay
Affects zookeeperSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 7.5 High : upgrade to 3.9.6 or 3.8.7 soon.
Data as of 1 Nov 2026, 22:58 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.9.6, 3.8.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 16 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade org.apache.zookeeper/zookeeper to 3.9.6 or 3.8.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavenorg.apache.zookeeper/zookeeperpkg:maven/org.apache.zookeeper/zookeeperOther threats | Affected
| Fixed in
|
Ubuntu Pro 14.04 LTSzookeeperpkg:deb/ubuntu/zookeeper?arch=source&distro=esm-infra-legacy/trustyOther threats | Affected
| Fixed in– |
Ubuntu Pro 16.04 LTSzookeeperpkg:deb/ubuntu/zookeeper?arch=source&distro=esm-apps/xenialOther threats | Affected
| Fixed in– |
Ubuntu Pro 18.04 LTSzookeeperpkg:deb/ubuntu/zookeeper?arch=source&distro=esm-apps/bionicOther threats | Affected
| Fixed in– |
Ubuntu 20.04 LTSzookeeperpkg:deb/ubuntu/zookeeper?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSzookeeperpkg:deb/ubuntu/zookeeper?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache ZooKeeper to versions 3.8.7 or 3.9.6 or later, where this vulnerability is fixed. No other mitigations are indicated in the advisory. Patch status is confirmed by the vendor advisory recommending these versions.
Description
CVE-2026-59739 is an information disclosure vulnerability in Apache ZooKeeper caused by a missing ACL check during SetWatches reconnect replay. An attacker can discover paths protected by ACLs by registering watches on non-existent paths and reconnecting after those paths are created with restricted ACLs. The vulnerability exposes the znode path but not its data. Since paths may contain sensitive information such as usernames or login IDs, this issue is potentially critical. The vulnerability affects multiple versions prior to 3.8.7 and 3.9.6. Upgrading to versions 3.8.7 or 3.9.6 resolves the issue.