CVE-2024-23944: Apache ZooKeeper · Information disclosure in persistent watcher handling
Affects zookeeperSource GCVE Database
Not known to be exploited : upgrade to 3.9.2 or 3.8.4 when convenient.
Data as of 26 Oct 2026, 17:16 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.9.2, 3.8.4
Exploitation evidence
Disclosed: evidence found.
CVE published 31 Mar 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade zookeeper to 3.9.2 or 3.8.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamizookeeperpkg:bitnami/zookeeperOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache ZooKeeper to version 3.8.4 or 3.9.2 or later, where this vulnerability is fixed. Applying these official fixes fully mitigates the issue.
Description
Apache ZooKeeper versions 3.6.0 through before 3.8.4 and 3.9.0 through before 3.9.2 contain an information disclosure vulnerability in the handling of persistent watchers. The issue arises from a missing ACL check when a persistent watcher is triggered, allowing an attacker with access to a parent znode to monitor child znodes and see their full paths. Although the znode data is not exposed, the path information can contain sensitive details such as usernames or login IDs. Upgrading to versions 3.8.4 or 3.9.2 resolves this vulnerability.