Skip to main content
CVE-2026-84501VulnerabilityPublished Updated

An unauthenticated attacker can inject arbitrary fake log lines into Apache ZooKeeper's operational log by sending a

Affects zookeeperSource GCVE Database

0
Compare
Authoritative record:CVE-2026-84501· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium · fixed in 3.8.7 : update zookeeper when convenient.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.8.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Mavenorg.apache.zookeeper/zookeeperpkg:maven/org.apache.zookeeper/zookeeperOther threatsAffected
  • >=3.8.0 <=3.8.6
  • >=3.9.0 <=3.9.5
Fixed in–
Ubuntu Pro 14.04 LTSzookeeperpkg:deb/ubuntu/zookeeper?arch=source&distro=esm-infra-legacy/trustyOther threatsAffected
  • =3.4.5+dfsg-1
  • =3.4.5+dfsg-1ubuntu0.1~esm1
  • =3.4.5+dfsg-1ubuntu0.1~esm3
Fixed in–
Ubuntu Pro 16.04 LTSzookeeperpkg:deb/ubuntu/zookeeper?arch=source&distro=esm-apps/xenialOther threatsAffected
  • 3.4.6-8 – 3.4.8-1ubuntu0.1~esm2
5 affected builds
Fixed in–
Ubuntu Pro 18.04 LTSzookeeperpkg:deb/ubuntu/zookeeper?arch=source&distro=esm-apps/bionicOther threatsAffected
  • 3.4.10-2 – 3.4.13-3ubuntu0.1~esm1
4 affected builds
Fixed in–
Ubuntu 20.04 LTSzookeeperpkg:deb/ubuntu/zookeeper?arch=source&distro=focalOther threatsAffected
  • 3.4.13-1 – 3.4.13-5ubuntu0.1
7 affected builds
Fixed in–
Ubuntu 22.04 LTSzookeeperpkg:deb/ubuntu/zookeeper?arch=source&distro=jammyOther threatsAffected
  • 3.4.13-5ubuntu4 – 3.4.13-6ubuntu4.1
5 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Apache ZooKeeper to version 3.8.7 or 3.9.6 or later, where this vulnerability is fixed. No other mitigation is indicated by the vendor advisory. Patch status is confirmed by the version upgrade information.

Description

Apache ZooKeeper versions 3.8.0 through 3.8.6 and 3.9.0 through 3.9.5 contain a vulnerability where an unauthenticated attacker can inject arbitrary fake log lines into the operational log by sending a crafted add_auth("ensemble", ...) request with newline characters. This causes the server to log unsanitized input, allowing forged log entries that appear indistinguishable from legitimate logs. Upgrading to versions 3.8.7 or 3.9.6 resolves the issue.

References

Community reviews

Loading reviews…