CVE-2026-105777: Insertion of Sensitive Information Into Sent Data in GitLab
Affects gitlabSource GCVE Database
Not known to be exploited · CVSS 4.3 Medium · fixed in 19.5.1 : update gitlab when convenient.
Data as of 29 Oct 2026, 14:41 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 19.5.1, 19.4.3, 19.3.6
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 21 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade gitlab to 19.5.1, 19.4.3 or 19.3.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official patches by upgrading to GitLab versions 19.3.6, 19.4.3, or 19.5.1 or later. Since patches are available, remediation should be performed promptly to prevent potential exploitation.
Description
A vulnerability in GitLab CE/EE versions from 17.6.5 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 allowed an unauthenticated user to retrieve sensitive internal server credentials due to improper filtering of internal response headers. This issue has been fixed in versions 19.3.6, 19.4.3, and 19.5.1.