Skip to main content
VulnerabilityPublished

CVE-2026-110264: GitLab · Integer Overflow or Wraparound

Affects gitlabSource GCVE Database

0
Compare
Authoritative record:CVE-2026-110264· Critical 10.0

Not known to be exploited · CVSS 10.0 Critical · fixed in 19.5.1 : patch gitlab as a priority.

Data as of 29 Oct 2026, 14:41 UTC

CVSS 3.1 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitLab)CVSS 3.110.0
EPSS
1.3% chance of exploitation in 30 days – higher than 70% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 19.5.1, 19.4.3, 19.3.6 +4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=7.0.0 <18.11.13
  • >=19.0.0 <19.0.10
  • >=19.1.0 <19.1.9
  • >=19.2.0 <19.2.9
  • >=19.3.0 <19.3.6
  • >=19.4.0 <19.4.3
  • >=19.5.0 <19.5.1
Fixed in
  • 18.11.13
  • 19.0.10
  • 19.1.9
  • 19.2.9
  • 19.3.6
  • 19.4.3
  • 19.5.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade to one of the fixed versions: 18.11.13, 19.0.10, 19.1.9, 19.2.9, 19.3.6, 19.4.3, or 19.5.1. Applying these updates will remediate the integer overflow flaw and prevent exploitation.

Description

A critical integer overflow vulnerability exists in GitLab CE/EE versions from 7.0 up to certain patched releases before 18.11.13 and 19.x series before specific patch versions. This flaw could allow an unauthenticated attacker to execute arbitrary code on the GitLab server by exploiting an integer overflow during the compilation of a specially crafted regular expression.

References

Community reviews

Loading reviews…