Skip to main content
CVE-2025-34301VulnerabilityPublished Updated

IPFire versions prior to 2.29 (Core Update 198) contain a stored cross-site scripting (XSS) vulnerability that allows

Source GCVE Database

0
Compare
Authoritative record:CVE-2025-34301· Medium 5.1

Not known to be exploited · CVSS 5.1 Medium · fixed in 2.29 : update web interface. IPFire when convenient.

Data as of 29 Oct 2026, 23:58 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
Affects
web interface. IPFire prior to 2.29
Patch
Available – fixed in 2.29
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

AI-suggested

Until then, restrict access to trusted users only and avoid viewing untrusted location groups.

Description

IPFire versions prior to 2.29 (Core Update 198) have a stored cross-site scripting (XSS) vulnerability in the COUNTRY_CODE parameter when creating a location group. An authenticated attacker can inject arbitrary JavaScript code that is stored and later executed in the context of other users viewing the affected page. This occurs because the parameter value is not properly sanitized or encoded before rendering in the web interface.

References

Community reviews

Loading reviews…