Skip to main content
VulnerabilityPublished

CVE-2025-34301: IPFire · XSS or 'Cross-site Scripting'

Affects IPFireSource CVE Database V5

0

Not known to be exploited · CVSS 5.1 Medium : upgrade to 2.29 when convenient.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
5.3% chance of exploitation in 30 days – higher than 92% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.29
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade IPFire to 2.29.

Affected software

ProductAffectedFixed in
IPFire.org IPFireAffected
  • <2.29
Fixed in
  • 2.29

AI-suggested

Organizations should immediately upgrade IPFire installations to version 2.29 (Core Update 198) or later, where this vulnerability is addressed. If upgrading is not immediately feasible, administrators should restrict access to the IPFire web interface to trusted networks and users only, employing strong authentication mechanisms such as multi-factor authentication (MFA). Additionally, monitoring and auditing of administrative actions and user accounts should be enhanced to detect suspicious activity. Web application firewalls (WAFs) or reverse proxies can be configured to sanitize or block suspicious input patterns targeting the COUNTRY_CODE parameter. Educating administrators about the risks of XSS and encouraging cautious handling of location group creation can reduce the likelihood of exploitation. Regular vulnerability scanning and penetration testing focused on the firewall management interface can help identify residual risks.

Description

IPFire versions prior to 2.29 (Core Update 198) contain a stored cross-site scripting (XSS) vulnerability that allows an authenticated attacker to inject arbitrary JavaScript code into the COUNTRY_CODE parameter when creating a location group. When a user adds a new location group, the application issues an HTTP POST request with the ACTION parameter set to savelocationgrp, and the value of the COUNTRY_CODE parameter determines the flag displayed for that group. The value of this parameter is stored and later rendered in the web interface without proper sanitization or encoding, allowing malicious scripts to be executed in the context of other users viewing the affected page.

References

Community reviews

Loading reviews…