IPFire versions prior to 2.29 (Core Update 198) contain a stored cross-site scripting (XSS) vulnerability that allows
Source GCVE Database
Not known to be exploited · CVSS 5.1 Medium : upgrade to 2.29 when convenient.
Data as of 29 Oct 2026, 23:58 UTC
- Patch
- Available – fixed in 2.29
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade ipfire/ipfire to 2.29.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ipfireipfire/ipfirepkg:rpm/ipfire/ipfireOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, restrict access to the service creation functionality to trusted users only and consider monitoring for suspicious activity related to service entries.
Description
IPFire versions prior to 2.29 (Core Update 198) have a stored cross-site scripting (XSS) vulnerability. This flaw allows an authenticated attacker to inject arbitrary JavaScript code via the PROT parameter when creating a new service. The injected script executes in the context of other users viewing the affected service entry due to improper sanitization of the stored input.