Skip to main content
CVE-2025-34316VulnerabilityPublished Updated

IPFire versions prior to 2.29 (Core Update 198) contain a stored cross-site scripting (XSS) vulnerability that allows

Source GCVE Database

0
Compare
Authoritative record:CVE-2025-34316· Medium 5.1

Not known to be exploited · CVSS 5.1 Medium · fixed in 2.29 : update affected systems when convenient.

Data as of 29 Oct 2026, 23:59 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.29
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

AI-suggested

A fix is available in IPFire version 2.29 (Core Update 198). Users should upgrade to this version or later to remediate the vulnerability. No other mitigation or workaround is indicated in the available data.

Description

IPFire versions prior to 2.29 (Core Update 198) have a stored cross-site scripting (XSS) vulnerability. An authenticated attacker can inject arbitrary JavaScript via the txt_mailuser and txt_mailpass parameters when updating mail server settings. These parameters are stored and later rendered without proper sanitization, enabling script execution in other users' browsers viewing the mail configuration.

References

Community reviews

Loading reviews…