Skip to main content
CVE-2024-5535VulnerabilityPublished Updated

Issue summary: Calling the OpenSSL API function SSL_select_next_proto with an empty supported client protocols buffer

Affects opensslSource GCVE Database

0
Compare

Not known to be exploited · CVSS 9.1 Critical · fixed in 1.0.1f-1ubuntu2.27+esm16 : patch openssl as a priority.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
5.5% chance of exploitation in 30 days – higher than 92% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.0.1f-1ubuntu2.27+esm16, 1.0.2g-1ubuntu4.20+esm18, 1.1.1-1ubuntu2.1~18.04.23+esm10 +8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Jun 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSedk2pkg:deb/ubuntu/edk2?arch=source&distro=nobleOther threatsAffected
  • <2024.02-2ubuntu0.6
Fixed in
  • 2024.02-2ubuntu0.6
Ubuntu 24.04 LTSopensslpkg:deb/ubuntu/openssl?arch=source&distro=nobleOther threatsAffected
  • <3.0.13-0ubuntu3.2
Fixed in
  • 3.0.13-0ubuntu3.2
Ubuntu Pro FIPS-updates 24.04 LTSopenssl-fipspkg:deb/ubuntu/openssl-fips?arch=source&distro=fips-updates/nobleOther threatsAffected
  • <3.0.13-0ubuntu3.6+Fips1
  • =3.0.13-0ubuntu3+Fips1
Fixed in
  • 3.0.13-0ubuntu3.6+Fips1
Ubuntu 22.04 LTSedk2pkg:deb/ubuntu/edk2?arch=source&distro=jammyOther threatsAffected
  • <2022.02-3ubuntu0.22.04.4
  • =2022.02~rc1-1
  • =2022.02~rc1-1ubuntu1
Fixed in
  • 2022.02-3ubuntu0.22.04.4
Ubuntu 22.04 LTSopensslpkg:deb/ubuntu/openssl?arch=source&distro=jammyOther threatsAffected
  • <3.0.2-0ubuntu1.17
Fixed in
  • 3.0.2-0ubuntu1.17
Ubuntu Pro 22.04 LTSnodejspkg:deb/ubuntu/nodejs?arch=source&distro=esm-apps/jammyOther threatsAffected
  • 12.22.5~dfsg-5ubuntu1 – 12.22.9~dfsg-1ubuntu3.6+esm2
12 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in updated OpenSSL package versions listed in the vendor advisory. Users should update to these fixed versions to remediate the issue. Due to the low severity and the nature of the vulnerability, no immediate emergency patch was issued, but the fix will be included in upcoming OpenSSL releases. Applications should ensure correct usage of SSL_select_next_proto, avoiding zero-length client protocol lists. Standard system updates and reboots are recommended to apply the fixes.

Description

A vulnerability in OpenSSL's SSL_select_next_proto API function can cause a crash or leak up to 255 bytes of memory to a peer when called with an empty client protocols buffer. This issue affects applications that improperly call this function with a zero-length client protocol list, which is typically a programming or configuration error. The flaw mainly impacts applications using the deprecated NPN protocol negotiation rather than the widely deployed ALPN. The vulnerability can lead to loss of confidentiality or denial of service but requires specific misconfigurations unlikely under attacker control. The issue is fixed in several updated OpenSSL package versions, and no new OpenSSL releases are currently issued due to the low likelihood of exploitation.

References

Community reviews

Loading reviews…