Skip to main content
CVE-2026-123014VulnerabilityPublished

iTerm2 before 3.7.7beta2 has an argument injection vulnerability in the x-man-page: URL handler, allowing an attacker

Affects iterm2Source GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-123014· High 8.7

Not known to be exploited · CVSS 8.7 High : upgrade to 3.7.7beta2 soon.

Data as of 5 Nov 2026, 07:26 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (mitre)CVSS 4.08.7
Patch
Available – fixed in 3.7.7beta2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade gnachman/iterm2 to 3.7.7beta2.

Affected software

ProductAffectedFixed in
GitHubgnachman/iterm2pkg:github/gnachman/iterm2Other threatsAffected
  • <3.7.7beta2
Fixed in
  • 3.7.7beta2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version 3.7.7beta2 or later addresses this vulnerability. Users should upgrade to iTerm2 version 3.7.7beta2 or later to remediate this issue. No other mitigations or workarounds are indicated in the provided data.

Description

iTerm2 versions before 3.7.7beta2 contain an argument injection vulnerability in the x-man-page URL handler. This flaw allows an attacker to execute arbitrary commands with the privileges of the logged-in user by tricking the user into opening a specially crafted URL. The vulnerability arises because percent-encoded NUL characters bypass input sanitization and are converted to whitespace during command-line parsing, enabling injection of additional arguments to the /usr/bin/man command, including the -P option to specify a malicious pager command. This issue is a regression due to an incomplete fix for CVE-2023-46321.

References

Community reviews

Loading reviews…