Joi 17.13.6 before 17.13.9 and 18.2.5 before 18.3.1 contains a prototype pollution vulnerability in lib/messages.js
Source GCVE Database
Not known to be exploited · CVSS 6.3 Medium : upgrade to 18.3.1 or 17.13.9 when convenient.
Data as of 4 Nov 2026, 22:52 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 6.3 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 3.7 |
- Patch
- Available – fixed in 18.3.1, 17.13.9
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 4 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade joi to 18.3.1 or 17.13.9.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| hapijsjoi | Affected
| Fixed in
|
| hapijsjoi | Affected
| Fixed in
|
npmjoipkg:npm/joiOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Joi versions 17.13.9 and later, and 18.3.1 and later. Users should upgrade to these versions or newer to remediate the vulnerability. No other mitigation steps are indicated.
Description
Joi versions 17.13.6 before 17.13.9 and 18.2.5 before 18.3.1 contain a prototype pollution vulnerability in the lib/messages.js file. The vulnerability arises because the compile() and merge() functions fail to reject a __proto__ language key. This allows attackers to supply untrusted message configurations that can replace the compiled messages prototype, potentially altering or breaking validation error rendering and any dependent logic.
References
- github.com/hapijs/joi/security/advisories/GHSA-6w3j-5fw6-r9vr (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-122131 (opens in a new tab)
- github.com/hapijs/joi/pull/3164 (opens in a new tab)
- github.com/hapijs/joi/commit/76f5771e1afe527cfda24be0e1a920ffa54888d6 (opens in a new tab)
- github.com/hapijs/joi/commit/dae9467cec27e787bfdea8b276595177d52d28ec (opens in a new tab)
- github.com/hapijs/joi (opens in a new tab)
- github.com/hapijs/joi/blob/v18.3.0/lib/messages.js (opens in a new tab)
- vulncheck.com/advisories/joi-17.13.6-before-17.13.9-and-18.2.5-before-18.3.1-prototype-replacement-via-proto-language-key (opens in a new tab)