Skip to main content
VulnerabilityPublished

CVE-2026-40171: Jupyter Notebook and JupyterLab token theft via stored XSS in help command linker

Affects jupyterlabSource GCVE Database

0
Authoritative record:CVE-2026-40171· High 8.4

Not known to be exploited · CVSS 8.4 High : upgrade to 4.5.7 soon.

Data as of 27 Oct 2026, 01:56 UTC

CVSS 4.0 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.5.7
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade jupyterlab to 4.5.7.

Affected software

ProductAffectedFixed in
Bitnamijupyterlabpkg:bitnami/jupyterlabOther threatsAffected
  • <4.5.7
Fixed in
  • 4.5.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Jupyter Notebook 7.5.6, JupyterLab 4.5.7, and the corresponding help-extension packages. Users should upgrade to these versions to remediate the vulnerability. As a temporary workaround, disable the affected help extensions or configure the sanitizer to set allowCommandLinker to false to prevent exploitation.

Description

A stored cross-site scripting (XSS) vulnerability exists in Jupyter Notebook (7.0.0 through 7.5.5) and JupyterLab (up to 4.5.6) in the help command linker. This flaw allows an attacker to craft malicious notebook content that, when interacted with by a user, can steal authentication tokens. Exploitation leads to full session takeover, enabling file access, code execution, and terminal creation. Fixed versions are Notebook 7.5.6 and JupyterLab 4.5.7.

References

Community reviews

Loading reviews…