Skip to main content
VulnerabilityPublished Updated

CVE-2024-47081: Lexicon · Requests vulnerable to .netrc credentials leak via malicious URLs

Affects lexiconSource GCVE Database

0
Compare
Authoritative record:CVE-2024-47081· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium : upgrade to 3.21.1_1 when convenient.

Data as of 30 Oct 2026, 07:45 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.21.1_1
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade lexicon to 3.21.1_1.

Affected software

ProductAffectedFixed in
Homebrewlexiconpkg:brew/lexiconOther threatsAffected
  • >=3.11.2 <3.21.1_1
Fixed in
  • 3.21.1_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Lexicon to version 3.21.1_1 or later where the vulnerability is fixed. For users unable to upgrade immediately, disable .netrc credential usage in Requests by setting trust_env=False on the Requests Session to prevent credential leakage.

Description

A URL parsing vulnerability in the Requests library prior to version 2.32.4 can cause leakage of .netrc credentials to third parties when processing certain malicious URLs. This issue affects Lexicon versions >=3.11.2 and <3.21.1_1. The vulnerability has a medium severity with a CVSS score of 5.3. A fix is available in version 3.21.1_1. As a workaround for older versions, disabling .netrc usage by setting trust_env=False in Requests sessions can mitigate the risk.

References

Community reviews

Loading reviews…