Skip to main content
CVE-2026-110944VulnerabilityPublished Updated

SUSE · libQt6HttpServer6-6.12.0-2.1 on GA media

Affects SUSESource GCVE Database

0
Compare
Authoritative record:CVE-2026-110944· Low 2.7

Not known to be exploited · CVSS 2.7 Low : upgrade SUSE qthttpserver to 6.12.1 or 6.11.3 when convenient.

Data as of 6 Nov 2026, 14:06 UTC

CVSS 4.0 base score
2.7Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (Qt)CVSS 4.02.7
Patch
Available – fixed in 6.12.1, 6.11.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L/E:U/R:U/RE:L/U:Green

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade Qt Framework and qt/qthttpserver to 6.12.1 or 6.11.3.

Affected software

ProductAffectedFixed in
qtQt FrameworkAffected
  • >=6.12.0 <6.12.1
Fixed in
  • 6.12.1
qtQt FrameworkAffected
  • >=6.4.0 <6.11.3
Fixed in
  • 6.11.3
GitHubqt/qthttpserverpkg:github/qt/qthttpserverOther threatsAffected
  • >=6.4.0 <6.11.3
  • >=6.12.0 <6.12.1
Fixed in
  • 6.11.3
  • 6.12.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should update to the libQt6HttpServer6-6.12.0-2.1 package on openSUSE Tumbleweed GA media to apply the security fixes. No additional mitigation guidance is provided.

Description

Multiple security issues have been addressed in the libQt6HttpServer6-6.12.0-2.1 package included in the GA media of openSUSE Tumbleweed. The specific vulnerabilities fixed are not detailed in the provided information.

References

Community reviews

Loading reviews…